RuneScape 2 Development > Downloads

[613/614]Revengescape NO ANTI-LEECH. Feel Free To Ask Me Question.

<<< (20/59) >>>

yelser:

--- Quote from: merk n a box on August 17, 2010, 11:08:35 AM ---
--- Quote from: Fire capez on August 17, 2010, 11:05:21 AM ---
--- Quote from: merk n a box on August 17, 2010, 11:04:44 AM ---
--- Quote from: ,Kate on August 17, 2010, 11:03:41 AM ---So what did you do then? Will you tell me so I can get mine running, please?

--- End quote ---

its a problem with that client

--- End quote ---

The ip or something actually wrong with the client lol?

--- End quote ---


no i dont think its that i used this client
 /file/cfm21ut048osvb7/613Loading614.rar

if you dont want to use this one try this
, go to Applet_Sub1.java and edit

if(string.equals("81.84.131.106"))

To 127.0.0.1 or w/e

and in
launch.java

--- End quote ---

try using that santa's. i did that and i think my client works now. i wont know until i can get my server to work. i just need the jvm.dll file in the server folder for jre6 update21 then im set

chostrider34:
to run the run.dat in your server open  C:/ then open Program Files go to Java then jre6, bin and now copie the map whit the name server and replace it whit the name Client.
and now you can run it and it works :)

yelser:
that didn't work for me...this is so fudgeing difficult  :mad: :( :confused: :confused:

okay, i went to jdk 6.1.0_21 and copied the jre folder and replaced jre6 update21 with that and it worked. but i got this when i tried to run the server.

,Kate:

--- Quote from: yelser on August 17, 2010, 12:10:31 PM ---
--- Quote from: ,Kate on August 17, 2010, 12:01:30 PM ---
--- Quote from: merk n a box on August 17, 2010, 11:57:57 AM ---
--- Quote from: ,Kate on August 17, 2010, 11:53:30 AM ---Ive got the client working, the cache in OS (C:/, and .ideas) But when I got to log on, *Unexpected server response*. I seriously don't know what is wrong  :confused: :confused: :confused: :(


--- End quote ---

edit: ~run
i dident have that problem but try opening launch.java replace it with

--- Code: ---import javax.swing.*;
import java.applet.Applet;
import java.awt.*;
import java.net.URL;
import java.util.Properties;

public class launch extends Applet {
    public static boolean rs = false;
    public static Properties aProperties1 = new Properties();
    public JFrame aJFrame2;
    public JPanel aJPanel3 = new JPanel();

    public static void main(String[] arg0) {
        if (arg0.length > 0) {
            if (arg0[0].equals("rs")) {
                rs = true;
            }
        }
        launch l = new launch();
        l.doFrame();
    }

    public void init() {
        doApplet();
    }

    void doApplet() {
        setParms();
        startClient();
    }

    public void doFrame() {
        setParms();
        openFrame();
        startClient();
    }

    void setParms() {
        aProperties1.put("cabbase", "urmom.cab");
        aProperties1.put("java_arguments", "-Xmx102m -Dsun.java2d.noddraw=true");
        aProperties1.put("colourid", "0");
        aProperties1.put("worldid", rs ? "16" : "3595");
        aProperties1.put("lobbyid", rs ? "1103" : "3595");
        aProperties1.put("lobbyaddress", rs ? "lobby17.runescape.com" : "127.0.0.1");
        aProperties1.put("demoid", "0");
        aProperties1.put("demoaddress", "");
        aProperties1.put("modewhere", "0");
        aProperties1.put("modewhat", "0");
        aProperties1.put("lang", "0");
        aProperties1.put("objecttag", "0");
        aProperties1.put("js", "1");
        aProperties1.put("game", "0");
        aProperties1.put("affid", "0");
        aProperties1.put("advert", "1");
        aProperties1.put("settings", "wwGlrZHF5gJcZl7tf7KSRh0MZLhiU0gI0xDX6DwZ-Qk");
        aProperties1.put("country", "0");
        aProperties1.put("haveie6", "0");
        aProperties1.put("havefirefox", "1");
        aProperties1.put("cookieprefix", "");
        aProperties1.put("cookiehost", ".runescape.com");
        aProperties1.put("cachesubdirid", "0");
        aProperties1.put("crashurl", "");
        aProperties1.put("unsignedurl", "");
        aProperties1.put("sitesettings_member", "1");
        aProperties1.put("frombilling", "false");
        aProperties1.put("sskey", "");
        aProperties1.put("force64mb", "false");
        aProperties1.put("worldflags", "8");
    }

    /*<param name="cabbase" value="gay.cab">
      <param name="java_arguments" value="-Xmx102m -Dsun.java2d.noddraw=true">
      <param name="colourid" value="0">
      <param name="worldid" value="74">
      <param name="lobbyid" value="1114">
      <param name="lobbyaddress" value="loby.unrealscape.com">
      <param name="demoid" value="901">
      <param name="demoaddress" value="demo.unrealcape.com">
      <param name="modewhere" value="0">
      <param name="modewhat" value="0">
      <param name="lang" value="0">
      <param name="objecttag" value="0">
      <param name="js" value="1">
      <param name="game" value="0">
      <param name="affid" value="0">
      <param name="advert" value="1">
      <param name="settings" value="wwGlrZHF5gJlp72Y1*JBwwTaTfiAxeL*KWZzFErDK-E">
      <param name="country" value="0">
      <param name="haveie6" value="0">
      <param name="havefirefox" value="1">
      <param name="cookieprefix" value="">
      <param name="cookiehost" value=".unrealscape.com">
      <param name="cachesubdirid" value="0">
      <param name="crashurl" value="blah">
      <param name="unsignedurl" value="blah">
      <param name="sitesettings_member" value="0">
      <param name="frombilling" value="false">
      <param name="sskey" value="">
      <param name="force64mb" value="false">
      <param name="worldflags" value="0">*/

    void openFrame() {
        aJFrame2 = new JFrame("Jagex");
        aJFrame2.setLayout(new BorderLayout());
        aJPanel3.setLayout(new BorderLayout());
        aJPanel3.add(this);
        aJPanel3.setPreferredSize(new Dimension(765, 503));
        aJFrame2.getContentPane().add(aJPanel3, "Center");
        aJFrame2.pack();
        aJFrame2.setVisible(true);
    }

    void startClient() {
        try {
            client.provideLoaderApplet(this);
            client var_client = new client();
            var_client.init();
            var_client.start();
        } catch (Exception e) {
            e.printStackTrace();
        }
    }

    public String getParameter(String arg0) {
        return (String) aProperties1.get(arg0);
    }

    public URL getDocumentBase() {
        return getCodeBase();
    }

    public URL getCodeBase() {
        URL url;
        try {
            if (rs) {
                url = new URL(";);
            } else {
                url = new URL(";);
            }
        } catch (Exception exception) {
            exception.printStackTrace();
            return null;
        }
        return url;
    }
}
--- End code ---

--- End quote ---

Ty, I'll try out. I won't even need 2 replace even If this doesn't solve the issue.

YES! Thanks so much. What I did also was change the IP: 81.84.131.106 in Applet_Sub1.java to my servers IP. So guys If you cant connect to the server, change the IP: 81.84.131.106 in Applet_Sub1.java to your own server IP! And DON'T change anything in Launch.java. Then compile, and run the run.bat file!

--- End quote ---

can you tell me how you got the server online? thats all i need. i have the ip in the client changed so that should work.

please, someone help me out with this.

EDIT: alright, i went into jdk files and copied the server file and pasted it into the jre bin files. i got a new error

its: Error occured during initialization of VM
unable to load native library: the specified procedure could not be found

okay, i know what i need. can someone who's server runs give me their jre6 update 21 jvm.dll file? just go to program files>java>jre6>bin>server. just try to upload that somewhere and give me the link. i thinks this will fix my problem thanks.

--- End quote ---

You put the cache into the C:/ directory, not into the JRE6 bin folder. Also, is your no-ip duc on? If not, switch it on. Make sure your server is on. And, make sure your ports are 43594, 43594. Check if your last-digit ip has changed from your router page aswell, by using PF Checker at Portforward.com.

Ok about the JRE6 thing. YOU NEED JR6 Update 21! Make sure the path is correct in your server. It is based on Program Files x86, you may have Windows 6!

yelser:
windows 6? I have vista...

and i dont really mean online. i just want to run the server on my computer so i can check it out.

guess i'll reinstall jre6 update 21 since i screwed it up

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version
Powered by SMFPacks SEO Pro Mod |