RuneScape 2 Development > Downloads

[718/753] Rune-Evo v3 - It's finally here! Content packed!

Pages: <<< (66/86) >>>

yoy426:

Add me on Skype if you think you could help me with the rune evo v3 source - skype = willspeed95@outlook.com

nervo:

use eclipse and there is also a tutorial on how to get it working.

mortal4combat:

how to remove it from the safemode??? it lagg as helll in my pc

LonelySouls:


--- Quote from: khayam on October 01, 2014, 05:28:07 AM ---ive tried everything but i cant make more than 1 owner? please help ive even tried this:

public boolean isOwner() {
  for (String name : Settings.OWNERS)
   if (username.equalsIgnoreCase(name))
    return true;
  return false;
 }

but still only 1 person can be owner how do i fix this?

--- End quote ---
Simple shit. You don't have to make a whole other thing for it.

1. On this advertisement where it shows you how to make yourself owner. Put YOUR account name there, in lowercase letters.

2. Since I doubt you have a Wiki Editor. Change all the properties of Wiki Editor (Meaning..Change every word "Wiki Editor" to "Owner")

3. In your Commands.java file. Where it says:
if (player.isOwner()) {
         if (Owner.processCommand(player, cmd, console, clientCommand)) {
            return true;
         }
      }

Add this:

if (player.isOwner() || player.isWikiEditor()) {
         if (Owner.processCommand(player, cmd, console, clientCommand)) {
            return true;
         }
      }

What this does, is give's the rank Wiki Editor (Recently changed to Owner, by YOU, in step 2) Owner commands, basically making a second owner.

There you go! All good!

Some Additional Stuff

If you want to go a step further and make it so you both have the same colored crown. Look up and download a sprite editor, open your cache, and where it shows the icon for Wiki editor ( green crown) simply change that image to a gold crown, Save.Compile.Complete.

[For using the Sprite Editor, Look up a tutorial on how to add new player ranks | changing rank icons]

Hope this helps

~+~ Lonely ~+~

   Developer || Owner

          LonelySouls!

runexmelon:

Guys, please help me. I have problem to run "start server - when i open it, its says "Missing server JVM" at c/programs files/java/jre1.8.0_25/bin/server/jvm.dll. what to do?

Pages: <<< (66/86) >>>

Go to full version