Welcome, guest! Please login or register.

    * Shoutbox

    RefreshHistory
    • FaTe_Of_GoDs: You guys have an offline client?
      Today at 03:25:13 AM
    • ASDss: where do u download source and clients now
      August 18, 2017, 10:39:31 PM
    • ASDss: yo
      August 18, 2017, 10:39:20 PM
    • dan v jad: click me 4 da fun ;)[link]
      August 18, 2017, 04:39:58 PM
    • stCky: Palidinho is your OpenGL (was it OpenGL?) stuff open source anywhere?
      August 16, 2017, 09:07:22 PM
    • Travas:BUILD THE WALL
      August 15, 2017, 09:28:49 PM
    • Travas: i have ass cancer
      August 15, 2017, 09:23:29 PM
    • stCky: what are the fudge are you tryna ask?
      August 15, 2017, 08:21:35 PM
    • bader: what are the rsps community alive ?
      August 15, 2017, 05:46:16 PM
    • bader: yo guys
      August 15, 2017, 05:46:08 PM
    • Spacehost:[link] Updated our thread :)
      August 15, 2017, 09:40:34 AM
    • Adaro: The client is in Download section at Homepage
      August 15, 2017, 01:09:20 AM
    • FaTe_Of_GoDs: where do i get the client?????????????
      August 14, 2017, 05:23:14 PM
    • stCky: can anyone help me? I cant login to the shoutbox
      August 13, 2017, 05:45:15 PM
    • drubrkletern: appeal denied
      August 13, 2017, 02:35:27 PM
    • King_Trout:[link]
      August 13, 2017, 11:17:12 AM
    • Cole1497: no sorry
      August 13, 2017, 10:27:14 AM
    • ayz: yo can anyone explain something to me
      August 13, 2017, 08:08:51 AM
    • coolking12: Hi
      August 13, 2017, 04:16:06 AM
    • stCky: n+1
      August 11, 2017, 06:09:24 PM

    Author Topic: RuneScape 530 - Xenorune  (Read 5299 times)

    0 Members and 1 Guest are viewing this topic.

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    RuneScape 530 - Xenorune
    « on: July 22, 2014, 08:20:08 PM »

    RuneScape 530 - Basically a lightly duct taped Xenorune.


    Things I've done to the server are located in a text file in the download.




    Media:



    Downloads:


    Note: the download contains a cache. It's the one that was released on R-S a while back that was 99.5% completed.


    /file/8cv1b1hk9vuuqx7/Updated530.zip


    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #1 on: July 22, 2014, 08:33:57 PM »
    Hey how do you set this up on Windows o.O


    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #2 on: July 22, 2014, 08:54:42 PM »
    Hey how do you set this up on Windows o.O
    Batch files or eclipse.


    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #3 on: July 22, 2014, 08:56:44 PM »
    You see I converted the files but it claims their are no java files in the folders where you kept Compile and Run

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #4 on: July 22, 2014, 08:57:57 PM »
    You see I converted the files but it claims their are no java files in the folders where you kept Compile and Run
    Point it to the src folder for compiling and the bin folder for running


    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #5 on: July 22, 2014, 09:03:15 PM »
    Server runs fine in Eclipse the only issue I have while compiling client is this

    Bad argument count, Usage: worldid, <live/rc/wip>, <english/german>, <game0/game1>

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #6 on: July 22, 2014, 09:04:46 PM »
    Server runs fine in Eclipse the only issue I have while compiling client is this

    Bad argument count, Usage: worldid, <live/rc/wip>, <english/german>, <game0/game1>
    Put arguments in there. It's giving you the choices you have.

    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #7 on: July 22, 2014, 09:18:18 PM »
    Out of curiosity and I hate to sound stupid but where exactly do the arguments go into? I went to run configuration and put those in but that error still shows up.

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #8 on: July 22, 2014, 09:19:19 PM »
    Out of curiosity and I hate to sound stupid but where exactly do the arguments go into? I went to run configuration and put those in but that error still shows up.
    I don't know, I don't use eclipse.

    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #9 on: July 22, 2014, 09:29:25 PM »
    Yo man the source is amazing :D but I ntocied the client is having an issue error_game_js5connect is what shows up when it says Connecting to Update Server. Where is the IP change located? And yes the server is running in the background via Eclipse so I don't know why it's not connecting to the server :S
    « Last Edit: July 22, 2014, 09:33:43 PM by icesteed »

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #10 on: July 22, 2014, 09:38:12 PM »
    Yo man the source is amazing :D but I ntocied the client is having an issue error_game_js5connect is what shows up when it says Connecting to Update Server. Where is the IP change located? And yes the server is running in the background via Eclipse so I don't know why it's not connecting to the server :S
    Run the server first, newer servers require the server to be running first in order for the client to load.

    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #11 on: July 22, 2014, 10:15:52 PM »
    Ok so here is what has happened. I joined the game and somethings still aren't working the quests are broken and the fighting seems to be not working either. I noticed that if I try hitting a goblin it will crash the game and say can't cast int to Object.

    Exception in thread "GameEngine" java.lang.Error: Unresolved compilation problem:
       Cannot cast from Object to int

       at com.xeno.content.LevelUp.levelUp(LevelUp.java:44)
       at com.xeno.model.player.Skills.addXp(Skills.java:145)
       at com.xeno.content.combat.Combat.addXp(Combat.java:525)
       at com.xeno.content.combat.Combat$1.execute(Combat.java:189)
       at com.xeno.event.Event.run(Event.java:81)
       at com.xeno.model.World.processEvents(World.java:221)
       at com.xeno.model.World.tick(World.java:288)
       at com.xeno.GameEngine.tick(GameEngine.java:121)
       at com.xeno.Server.processEvents(Server.java:180)
       at com.xeno.Server.go(Server.java:116)
       at com.xeno.Main$1.run(Main.java:35)
       at java.lang.Thread.run(Unknown Source)
    [2014/07/22 23:13:58] [AnonymousIoService-4]: Unkown length: 229, guessed to be: 3.

    Offlinesk8rdude461

    • MOPARSCAPE WAS HACKED
    • Member
    • ****
    • *
    • Posts: 12,471
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #12 on: July 22, 2014, 10:43:41 PM »

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #13 on: July 23, 2014, 11:23:46 AM »
    Ok so here is what has happened. I joined the game and somethings still aren't working the quests are broken and the fighting seems to be not working either. I noticed that if I try hitting a goblin it will crash the game and say can't cast int to Object.

    Exception in thread "GameEngine" java.lang.Error: Unresolved compilation problem:
       Cannot cast from Object to int

       at com.xeno.content.LevelUp.levelUp(LevelUp.java:44)
       at com.xeno.model.player.Skills.addXp(Skills.java:145)
       at com.xeno.content.combat.Combat.addXp(Combat.java:525)
       at com.xeno.content.combat.Combat$1.execute(Combat.java:189)
       at com.xeno.event.Event.run(Event.java:81)
       at com.xeno.model.World.processEvents(World.java:221)
       at com.xeno.model.World.tick(World.java:288)
       at com.xeno.GameEngine.tick(GameEngine.java:121)
       at com.xeno.Server.processEvents(Server.java:180)
       at com.xeno.Server.go(Server.java:116)
       at com.xeno.Main$1.run(Main.java:35)
       at java.lang.Thread.run(Unknown Source)
    [2014/07/22 23:13:58] [AnonymousIoService-4]: Unkown length: 229, guessed to be: 3.
    It just hit me why the client didn't work. It's because there is no cache in the client.

    OfflineAshi

    • Member
    • ****
    • Posts: 3,585
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #14 on: July 23, 2014, 11:28:49 AM »
    What did you add? I'm not interested in downloading and finding out, but curious.

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #15 on: July 23, 2014, 11:30:19 AM »
    What did you add? I'm not interested in downloading and finding out, but curious.
    Not much, a better dialogue system and basic shit like correct messages and bank space counter haha. Also I made it autosave players once in a while.

    OfflineTitanium_

    • Member
    • ***
    • Posts: 169
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #16 on: July 23, 2014, 11:30:40 AM »
    Nice contribution to the community :)
    Rune-Server Name: Titanium
    Moparscape Name: Titanium_
    RL Name: Titanium
    Check out Multimods Project Thread: http://www.moparscape.org/smf/index.php/topic,648286.0.html
    MultiMods official website: http://multimods.org

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #17 on: July 23, 2014, 11:32:08 AM »
    Oh yeah forgot to mention I also have the correct skill icon thing flashing in the skill tab when you level up :D

    Offlineicesteed

    • Member
    • **
    • Posts: 17
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #18 on: July 23, 2014, 11:58:33 AM »
    LOL limits :D did you add the cache to the client or server???

    OfflineLimits

    • Member
    • ****
    • Posts: 2,190
    • Thanks: +0/-0
      • View Profile
    Re: RuneScape 530 - Xenorune
    « Reply #19 on: July 23, 2014, 11:59:39 AM »
    LOL limits :D did you add the cache to the client or server???
    It's located server side in the data folder because the server loads the cache as well. Copy the files in there and put it in the 'rscache' folder client sided.

     

    Copyright © 2017 MoparScape. All rights reserved.
    Powered by SMFPacks SEO Pro Mod |
    SimplePortal 2.3.5 © 2008-2012, SimplePortal