Welcome, guest! Please login or register.

    * Shoutbox

    RefreshHistory
    • Cole1497: join horney scape we are horney all the time and have a sex emote
      November 09, 2019, 05:14:33 PM
    • thewraith500: try autoscape,0rg brand new osrs CUSTOMS server! fight caves for flaming fire cape, upgrade them to infernal wings + more!
      November 09, 2019, 01:37:29 AM
    • SuperNativeZ: Come play brand new server [link]
      November 08, 2019, 02:13:24 PM
    • SuperNativeZ: Come play brand new server [link]
      November 08, 2019, 02:13:17 PM
    • SuperNativeZ: Come play brand new server [link]
      November 08, 2019, 02:13:14 PM
    • ragnoroker: Brand new server, come join the fun - unique server - RuneGuild - [link]
      November 07, 2019, 11:55:44 AM
    • ragnoroker: Brand new server, come join the fun - unique server - RuneGuild - [link]
      November 07, 2019, 11:55:40 AM
    • ragnoroker: Brand new server, come join the fun - unique server - RuneGuild - [link]
      November 07, 2019, 11:55:35 AM
    • ArtexAdv: Come play brand new server [link]
      November 07, 2019, 07:36:34 AM
    • grefin::cool:
      November 04, 2019, 12:55:57 AM
    • grefin: Hi friends! I cant get through that bank pin thing. What should i do my friends?
      November 04, 2019, 12:55:36 AM
    • cows1471: its weird
      November 03, 2019, 02:56:40 PM
    • cows1471: fudge me
      November 03, 2019, 02:56:34 PM
    • cows1471: my original account is 11 years ago
      November 03, 2019, 02:56:26 PM
    • cows1471: and yet
      November 03, 2019, 02:56:14 PM
    • Christmas_tree: this place has changed
      November 03, 2019, 02:54:34 PM
    • Christmas_tree: fudge me
      November 03, 2019, 02:54:25 PM
    • Christmas_tree: six years ago i registered this account
      November 03, 2019, 02:54:22 PM
    • thewraith500: everyone join autoscape,0rg its the best customs osrs server yet! the owner gives ultra boxes!
      October 28, 2019, 08:03:09 PM
    • gameruler93: I am so fudgeing glad to see this website is still alive.
      October 28, 2019, 07:57:18 PM

    Author Topic: Loading 194 maps  (Read 1164 times)

    0 Members and 1 Guest are viewing this topic.

    OfflineAmbokile

    • Member
    • ****
    • Posts: 3,009
    • Thanks: +0/-0
      • View Profile
    Loading 194 maps
    « on: November 12, 2014, 04:38:35 PM »
    I'm having some trouble loading up Scu11's 194 maps in the 194 client. In the loadRegion method, when the client grabs the first int from the compressed map file as the "size" of the file, for some reason it always grabs the size as 0. I opened up the map file in a hex editor and saw that there was data in the first 8 hex columns (1F 8B 08 00 00 00 00 00).

    Here is the code in question:

    Code: [Select]
    for (int r = 0; r < regionCount; r++) {
    byte[] data = landscapeData[r];

    System.out.println("loadRegion: landscapeData[" + r + "] " + ((data == null) ? "does not exist" : "exists"));

    if (data != null) {
    Stream stream = new Stream(data);
    int size = stream.getInt();

    System.out.println("apparent uncompressed size of " + size + " " + data.length);
    BZ2Decompressor.decompressBuffer(worldData, size, data, data.length - 4, 4);
    int regionX = (regionCoordinates[r] >> 8) * 64 - baseX;
    int regionY = (regionCoordinates[r] & 0xff) * 64 - baseY;
    region.loadLandscapeBlock(worldData, aClass22_882, currentCollisionMap,
    worldController, regionY, regionX, -576);
    }
    }

    When the region is loaded, the client says this:
    Quote
    loadRegion: landscapeData[0] exists
    apparent uncompressed size of 0 4784

    The file ("l50_50") has a compressed size of 4.787kb so this suits the code. It has an uncompressed size of 8.312kb, however the first 8 nybbles from the compressed file's data (1F 8B 08 00 00 00 00 00) makes (2272919233031569408) which doesn't suit the code. What am I doing wrong?
    Runescape Gambling

    Offlinejediz

    • Member
    • **
    • Posts: 39
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #1 on: November 12, 2014, 07:44:28 PM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    Offlinet4

    • Member
    • ****
    • *
    • *
    • *
    • Posts: 6,798
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #2 on: November 12, 2014, 10:37:26 PM »
    afaik there isn't a complete 194 cache

    OfflineAmbokile

    • Member
    • ****
    • Posts: 3,009
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #3 on: November 13, 2014, 10:38:03 AM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    well i fixed it so cheers buddy



    afaik there isn't a complete 194 cache

    The client-side cache is complete however the maps were loaded from the server and so are incomplete (or so the tale goes). I'm going to load the 289 terrain data (as above) in 194 format, and then use the 289 object data to put the objects in the right position but will be using their 194 definitions and models.

    Offlinejediz

    • Member
    • **
    • Posts: 39
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #4 on: November 13, 2014, 10:45:29 AM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    well i fixed it so cheers buddy



    afaik there isn't a complete 194 cache

    The client-side cache is complete however the maps were loaded from the server and so are incomplete (or so the tale goes). I'm going to load the 289 terrain data (as above) in 194 format, and then use the 289 object data to put the objects in the right position but will be using their 194 definitions and models.

    I wouldn't call it close to being fixed.


    OfflineAmbokile

    • Member
    • ****
    • Posts: 3,009
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #5 on: November 13, 2014, 10:53:01 AM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    well i fixed it so cheers buddy

    [img]http://i.imgur.com/RQCyRdm.png[/im g]

    I wouldn't call it close to being fixed.

    [img]http://i.imgur.com/removed.png[/im g]

    Why not? The map data is loading correctly which is what I set out to do ;)

    Your client does look good though - how much work have you done to it?

    Offlinejediz

    • Member
    • **
    • Posts: 39
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #6 on: November 13, 2014, 11:33:59 AM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    well i fixed it so cheers buddy

    [img]http://i.imgur.com/RQCyRdm.png[/im g]

    I wouldn't call it close to being fixed.

    [img]http://i.imgur.com/removed.png[/im g]

    Why not? The map data is loading correctly which is what I set out to do ;)

    Your client does look good though - how much work have you done to it?

    No, only landscapes appear to be present. Also it appears as if you've hacked the client to load landscapes without player or NPC updating.

    My client is the original 194 client loading 289 maps/models. However the original 194 models are intact for objects, NPCs, etc. The server at this point is just about ready for content development.

    OfflineAmbokile

    • Member
    • ****
    • Posts: 3,009
    • Thanks: +0/-0
      • View Profile
    Re: Loading 194 maps
    « Reply #7 on: November 13, 2014, 12:42:02 PM »
    That data is mine, and does not belong to Scu11. I released that cache to troll people; Scu11 just re-posted it. This data is practically useless without the original 194 client that goes with my server.

    well i fixed it so cheers buddy

    [img]http://i.imgur.com/RQCyRdm.png[/im g]

    I wouldn't call it close to being fixed.

    [img]http://i.imgur.com/removed.png[/im g]

    Why not? The map data is loading correctly which is what I set out to do ;)

    Your client does look good though - how much work have you done to it?

    No, only landscapes appear to be present. Also it appears as if you've hacked the client to load landscapes without player or NPC updating.

    My client is the original 194 client loading 289 maps/models. However the original 194 models are intact for objects, NPCs, etc. The server at this point is just about ready for content development.

    Player updating is there, just with dummy data at the moment :P

     

    Copyright © 2017 MoparScape. All rights reserved.
    Powered by SMFPacks SEO Pro Mod |
    SimplePortal 2.3.5 © 2008-2012, SimplePortal