RuneScape Classic > RSC Server Development / Discussion

RSC Private Server Tutorials.

<<< (3/20) >>>

I Unrealpk I:
Please Help. I didnt want to start a new topic, so i posted here. I keep getting the following:

Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre6\li
b\tools.jar
Buildfile: build.xml

runserver:
     [java] RSCD Server starting up...
     [java] Attempting to connect to LS
     [java] Registering world (30) with LS
     [java]
     [java] <-- Loading Quest class files -->
     [java]
     [java]  - Loaded:   testquest
     [java]
     [java] <-- 1 Quest class files loaded -->
     [java]
     [java] GameEngine now running
     [java] World successfully registered with LS
     [java] java.net.BindException: Address already in use: bind
     [java]     at sun.nio.ch.Net.bind(Native Method)
     [java] RSCD Server shutting down...
     [java] Unregistering world (30) with LS
     [java]     at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
     [java]     at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor.registerN
ew(SocketAcceptor.java:363)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor.access$80
0(SocketAcceptor.java:55)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.ru
n(SocketAcceptor.java:222)
     [java]     at org.apache.mina.util.NamePreservingRunnable.run(NamePreservin
gRunnable.java:51)
     [java]     at java.lang.Thread.run(Unknown Source)
     [java] Terminating GameEngine

This is on a rscd based server. I searched the forums and tried all the stuff and couldnt get it working.

LsConfig



<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>RSCD-LS Config</comment>
   <entry key="mysqlhost">localhost</entry>
   <entry key="mysqldb">rscd</entry>
   <entry key="mysqluser">root</entry>
   <entry key="mysqlpass"></entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
   <entry key="queryip">mylanip</entry>
   <entry key="queryport">8181</entry>
</properties>

-------------------------------------------------------
world.xml

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>RSCD Config</comment>
   <entry key="version">31</entry>
   <entry key="ip">mylanip</entry>
   <entry key="port">43590</entry>
   <entry key="name">RSCDaemon</entry>
   <entry key="location">Scotland</entry>
   <entry key="maxplayers">800</entry>
   <entry key="servernum">30</entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
</properties>

_________________________________________---
settings ini

server=mylanip
port=43590
config_dir=clientconf
media_dir=media
movie_fps=5

_____________________________
C:\Documents and Settings\Unreal\Desktop\RscDev\Rscd_v25\Rscd v25\conf\server\conf.xml
<?xml version="1" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>Demonik Config</comment>
   <entry key="version">31</entry>
   <entry key="ip">mylanip</entry>
   <entry key="port">43590</entry>
   <entry key="name">DemonikOnline</entry>
   <entry key="location">Dallas</entry>
   <entry key="maxplayers">800</entry>
   <entry key="servernum">3</entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
</properties>


______________________________

I tried changing ports, restarting. Help please.

darkgirl861:
dang nice guide

elyad:
Pm me I Unrealpk I your email addy, And il talk you over your problem.

l0llip0p:
Nice but didn't understand nothing myself.

Lavoris:

--- Quote from: I Unrealpk I on September 21, 2008, 01:43:30 AM ---Please Help. I didnt want to start a new topic, so i posted here. I keep getting the following:

Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre6\li
b\tools.jar
Buildfile: build.xml

runserver:
     [java] RSCD Server starting up...
     [java] Attempting to connect to LS
     [java] Registering world (30) with LS
     [java]
     [java] <-- Loading Quest class files -->
     [java]
     [java]  - Loaded:   testquest
     [java]
     [java] <-- 1 Quest class files loaded -->
     [java]
     [java] GameEngine now running
     [java] World successfully registered with LS
     [java] java.net.BindException: Address already in use: bind
     [java]     at sun.nio.ch.Net.bind(Native Method)
     [java] RSCD Server shutting down...
     [java] Unregistering world (30) with LS
     [java]     at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
     [java]     at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor.registerN
ew(SocketAcceptor.java:363)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor.access$80
0(SocketAcceptor.java:55)
     [java]     at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.ru
n(SocketAcceptor.java:222)
     [java]     at org.apache.mina.util.NamePreservingRunnable.run(NamePreservin
gRunnable.java:51)
     [java]     at java.lang.Thread.run(Unknown Source)
     [java] Terminating GameEngine

This is on a rscd based server. I searched the forums and tried all the stuff and couldnt get it working.

LsConfig



<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>RSCD-LS Config</comment>
   <entry key="mysqlhost">localhost</entry>
   <entry key="mysqldb">rscd</entry>
   <entry key="mysqluser">root</entry>
   <entry key="mysqlpass"></entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
   <entry key="queryip">mylanip</entry>
   <entry key="queryport">8181</entry>
</properties>

-------------------------------------------------------
world.xml

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>RSCD Config</comment>
   <entry key="version">31</entry>
   <entry key="ip">mylanip</entry>
   <entry key="port">43590</entry>
   <entry key="name">RSCDaemon</entry>
   <entry key="location">Scotland</entry>
   <entry key="maxplayers">800</entry>
   <entry key="servernum">30</entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
</properties>

_________________________________________---
settings ini

server=mylanip
port=43590
config_dir=clientconf
media_dir=media
movie_fps=5

_____________________________
C:\Documents and Settings\Unreal\Desktop\RscDev\Rscd_v25\Rscd v25\conf\server\conf.xml
<?xml version="1" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://www.oracle.com/technetwork/java/index.html;>
<properties>
   <comment>Demonik Config</comment>
   <entry key="version">31</entry>
   <entry key="ip">mylanip</entry>
   <entry key="port">43590</entry>
   <entry key="name">DemonikOnline</entry>
   <entry key="location">Dallas</entry>
   <entry key="maxplayers">800</entry>
   <entry key="servernum">3</entry>
   <entry key="lsip">mylanip</entry>
   <entry key="lsport">43590</entry>
</properties>


______________________________

I tried changing ports, restarting. Help please.

--- End quote ---




if I can recall it's probably because your java or, ls server is already running.... only if your on a vista this happens, it's not really the server issue, more of a vista problem>

Ctrl + alt + delete and find java.exe delete them, then try running the ls and server bats, that should fix it.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version
Powered by SMFPacks SEO Pro Mod |