Welcome, guest! Please login or register.

    * Shoutbox

    RefreshHistory
    • Striker Fox2: download it
      Today at 03:26:06 AM
    • Zezuma09: how do i get this game started ?
      October 22, 2017, 03:24:27 AM
    • Striker Fox2: Much more on General Board
      October 21, 2017, 04:30:25 AM
    • Striker Fox2: New price guide link [link]
      October 21, 2017, 04:30:18 AM
    • Striker Fox2: New discord link [link]
      October 21, 2017, 04:30:03 AM
    • Saltyspade10: If you are new and reading this, stick around becaus it's a great server and community! Hope to see you in-game :)
      October 21, 2017, 02:44:16 AM
    • damian6: hello i wanne buy this server can u add me
      October 20, 2017, 03:54:38 PM
    • Wilkooo: lol jks
      October 20, 2017, 02:39:53 PM
    • Wilkooo: ilyall
      October 20, 2017, 02:39:48 PM
    • tm4dz: why cant i see any download links??
      October 20, 2017, 10:46:55 AM
    • stCky: u dont need to its fudgeing sick
      October 19, 2017, 08:13:13 PM
    • odin stormborn: how do i change my username
      October 19, 2017, 12:16:51 PM
    • qazplm102938: everyone play manicps its best server out there loads to do its badboyyyy - manicps manicps shout out kiteshield
      October 19, 2017, 10:28:21 AM
    • qazplm102938: everyone play manicps its best server out there loads to do its badboyyyy - manicps manicps
      October 19, 2017, 10:11:08 AM
    • Travas: wtf
      October 19, 2017, 07:37:52 AM
    • stCky: Adaro, you are a threat to the communities image, yes
      October 18, 2017, 02:53:43 PM
    • Krackkid: Hello everyone it is I, Krackkid.
      October 18, 2017, 07:21:56 AM
    • soma_: Does anyone have an updated link to a blank Source / Client? 317/508
      October 18, 2017, 04:57:44 AM
    • michaeltrailer: olm t pst
      October 18, 2017, 04:52:48 AM
    • Adaro: Strange that staff think I'm a threat when I'm not threatening anyone
      October 18, 2017, 03:07:16 AM

    Author Topic: 718 Run error  (Read 276 times)

    0 Members and 1 Guest are viewing this topic.

    Offlinefpsnipmob

    • Member
    • ***
    • Posts: 181
    • Thanks: +0/-0
      • View Profile
    718 Run error
    « on: March 27, 2015, 10:02:44 PM »
    so i was editing shop locations, and added server to eclipse and when i randomly started getting this run error, both compile and run are using the same JDK, not sure what i did.  :palm:

    Code: [Select]
    [GTLVote V1.1] Settings initializing...
    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/mysql/jdb
    c/Driver : Unsupported major.minor version 52.0
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
    2)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
            at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:191)
            at org.Vote.Connect.connect(Connect.java:17)
            at org.Vote.MainLoader.<init>(MainLoader.java:22)
            at com.rs.Launcher.<clinit>(Launcher.java:137)
    Press any key to continue . . .

    Let me know if you need file code too :) thanks

    Offlinesk8rdude461

    • MOPARSCAPE WAS HACKED
    • Member
    • ****
    • *
    • Posts: 12,471
    • Thanks: +0/-0
      • View Profile
    Re: 718 Run error
    « Reply #1 on: March 28, 2015, 12:19:43 AM »
    You compiled a file on JDK 1.8, and are trying to run the file using a lower version of Java.

    Remove any version of Java that is lower than version 1.8, and make sure to edit your run.bat/compiler accordingly.

    If you manually did your environmental variables (windows usually), then you need to update those as well.


    Offlinefpsnipmob

    • Member
    • ***
    • Posts: 181
    • Thanks: +0/-0
      • View Profile
    Re: 718 Run error
    « Reply #2 on: March 28, 2015, 08:31:33 PM »
    i just added the files i edited to a backup and it works fine. and i was compiling and running with 1.7**


    Offlinesk8rdude461

    • MOPARSCAPE WAS HACKED
    • Member
    • ****
    • *
    • Posts: 12,471
    • Thanks: +0/-0
      • View Profile
    Re: 718 Run error
    « Reply #3 on: March 29, 2015, 12:11:11 AM »
    Well.. The error specified is because a file or files were compiled on Java 1.8. And you're running it on Java version 1.7

    Again. Upgrade to 1.8, and change all your compilers/run.bats/Environmental Variables.
    And then recompile, then run.

     

    Copyright © 2017 MoparScape. All rights reserved.
    Powered by SMFPacks SEO Pro Mod |
    SimplePortal 2.3.5 © 2008-2012, SimplePortal