Welcome, guest! Please login or register.

    * Shoutbox

    RefreshHistory
    • King Bosnia: Any recommendations to private servers?
      October 18, 2018, 04:47:35 PM
    • FightMexoxo: oi i have the files if anyone whats em
      October 18, 2018, 12:44:42 AM
    • The Wanderer: Whoops
      October 15, 2018, 12:56:18 AM
    • The Wanderer: Making own operating system
      October 15, 2018, 12:56:11 AM
    • Travas: no
      October 07, 2018, 04:03:36 PM
    • Saltyspade10: Server still up and running?
      October 05, 2018, 07:13:41 PM
    • Wesam: Can someone upload moparscape.jar?
      October 05, 2018, 11:43:43 AM
    • Ligoe: yo
      September 30, 2018, 12:48:15 PM
    • Ligoe: how come i can't login the game
      September 30, 2018, 12:48:03 PM
    • fuzzout: Anybody here with experience in using Luna source? I'm looking to develop something, but can't seem to get any of my clients to work with it...
      September 26, 2018, 10:47:27 AM
    • `Discardedx2`: ?
      September 21, 2018, 12:24:09 PM
    • Pookey71: ARE YOU HERE TO RECEIVE MY LIMP PENIS!?
      September 20, 2018, 11:55:24 PM
    • Pookey71: THIS IS DEMOCRACY MANIFESTO
      September 20, 2018, 11:55:07 PM
    • Vasi28: Гранд
      September 03, 2018, 07:06:22 PM
    • Rash: test
      August 30, 2018, 09:09:18 PM
    • Guruu:[link]
      August 30, 2018, 12:04:45 AM
    • Guruu: am i allowed to post links shoutbox?
      August 30, 2018, 12:03:46 AM
    • drubrkletern:[link] feedback wanted
      August 28, 2018, 03:55:17 PM
    • bugz000: Anyone got a link for the old ass silab client and cache.zip? from mopar 3.2 era :) 317
      August 25, 2018, 12:48:15 AM
    • cholland2015: Does anyone know where I can download the old moparscape client/server?
      August 24, 2018, 02:30:51 PM

    Author Topic: Need help putting server online Eclipse (pictures showing how I set it all up)  (Read 717 times)

    0 Members and 1 Guest are viewing this topic.

    Offlinepopcorn57

    • Member
    • **
    • Posts: 53
    • Thanks: +0/-0
      • View Profile
    I am new to coding and I am trying to run epicurus through eclipse. But every time I start the source. This pops up.







    And this is how I setted the server up through eclipse.


    Server Folder:









    Created new java project:







    Then I went to run configurations and selected these options:








    Here are where it is saying the errors are:

    Serverpanel.java, 282:








    Playerhandler.java, 19, 29






    Then I tried to run It by pressing the green run/start button at the top. Then it still gives me that error. Any help would be greatly appreciated. Thanks!


    « Last Edit: July 28, 2015, 01:47:52 PM by popcorn57 »
    Runescape Gambling

    OfflinePest

    • Member
    • ***
    • Posts: 222
    • Thanks: +0/-0
      • View Profile
    just open the entire server into Eclipse, and hit the green button lol :palm:
    Runescape Gambling

    Offlinepopcorn57

    • Member
    • **
    • Posts: 53
    • Thanks: +0/-0
      • View Profile
    just open the entire server into Eclipse, and hit the green button lol :palm:
    And that is why I am here because that is not working lol
    Runescape Gambling

    OfflineJustin Bieber

    • Member
    • ****
    • Posts: 2,941
    • Thanks: +0/-0
      • View Profile
    why would you even want to run a production server in eclipse?

    Offlinesk8rdude461

    • MOPARSCAPE WAS HACKED
    • Member
    • ****
    • *
    • Posts: 12,471
    • Thanks: +0/-0
      • View Profile
    Check your config for what the variable "MAX_PLAYERS" is set to.
    It seems that's a negative value, thus setting the players array to a negative, creating your error seen in the console.

    Offlinepopcorn57

    • Member
    • **
    • Posts: 53
    • Thanks: +0/-0
      • View Profile
    why would you even want to run a production server in eclipse?

    Only because there is no compiler in the original source. And I tried a few but none of them worked so people pointed me to eclipse. If I could find a good working compiler I would much prefer that!

    Check your config for what the variable "MAX_PLAYERS" is set to.
    It seems that's a negative value, thus setting the players array to a negative, creating your error seen in the console.

    Thanks for the reply Sk8r I did switch it, and it got rid of all of those errors thank you! But now it is just saying "failure starting up world" in the console

    Offlinesk8rdude461

    • MOPARSCAPE WAS HACKED
    • Member
    • ****
    • *
    • Posts: 12,471
    • Thanks: +0/-0
      • View Profile
    trace the message back to it's origin and see why it's printing it.
    that's not a java error message, that's a user defined one, so it should be in the code.

    Offlinemalimt

    • Member
    • ****
    • Posts: 472
    • Thanks: +0/-0
      • View Profile
    why would you even want to run a production server in eclipse?

    Only because there is no compiler in the original source. And I tried a few but none of them worked so people pointed me to eclipse. If I could find a good working compiler I would much prefer that!

    Check your config for what the variable "MAX_PLAYERS" is set to.
    It seems that's a negative value, thus setting the players array to a negative, creating your error seen in the console.

    Thanks for the reply Sk8r I did switch it, and it got rid of all of those errors thank you! But now it is just saying "failure starting up world" in the console
    Believe me you'd be much better off with Eclipse... It seems a bit complex at first, but once you really get into it.... It's there absolute best!

     

    Copyright © 2017 MoparScape. All rights reserved.
    Powered by SMFPacks SEO Pro Mod |
    SimplePortal 2.3.5 © 2008-2012, SimplePortal