Welcome, guest! Please login or register.

    * Shoutbox

    RefreshHistory
    • OracleScape: Bump my server and play [link]
      Today at 06:08:29 PM
    • OracleScape: BUMP my thread please [link]
      Today at 06:08:00 PM
    • stCky: idk man im just a chat bot
      August 22, 2017, 11:14:52 PM
    • symantec: is this forum
      August 22, 2017, 09:02:56 PM
    • symantec: what the fudge
      August 22, 2017, 09:02:52 PM
    • symantec: I just joined to download datmaker, the links are broken and a user named i nelson i has a fudgeing weird signature
      August 22, 2017, 08:59:33 PM
    • stCky: ur so cool and edgy
      August 22, 2017, 04:15:50 PM
    • Deathspirit: anyways, i'm un ip banned now.. but don't even want to be that at this point lmfao
      August 22, 2017, 01:58:14 PM
    • Deathspirit: now it's some sell out half leeched server :')
      August 22, 2017, 01:57:53 PM
    • Deathspirit: gf moparscape, was the best rsps community i've been on since 2006
      August 22, 2017, 01:57:31 PM
    • stCky: yeah, nah. it's cooked. [link] might help u with a backup or something idk man im just a chat bot
      August 22, 2017, 12:13:25 AM
    • flew420: I sure hope someone has a copy of the forum before it was recked
      August 21, 2017, 11:40:52 PM
    • flew420: O wow i see now, just read thru all the news articles. :(  i've been out of the game for a couple years so coming back to this shit is sad.
      August 21, 2017, 11:39:46 PM
    • flew420: Huh?
      August 21, 2017, 10:49:51 PM
    • stCky: got bought by a russian dude, he put a shitty rsps on it for donations, now no one cares
      August 21, 2017, 10:48:30 PM
    • flew420: I came on for some nostalgic reading in old classic development, and it only goes back to 2014 wtf.
      August 21, 2017, 10:43:09 PM
    • flew420: what happened to this site??
      August 21, 2017, 10:42:36 PM
    • Sean56:[link]
      August 21, 2017, 05:33:45 PM
    • kb010: how can i play? i downloaded the client and it doesnt open.
      August 21, 2017, 10:52:56 AM
    • wodkode: shut it down or fix it
      August 20, 2017, 10:11:28 PM

    Author Topic: [6-16-2014] How to setup RS3, RS2 and RS1 Server in Eclipse IDE Part 2  (Read 4471 times)

    0 Members and 1 Guest are viewing this topic.

    OfflineIfearI

    • Member
    • ***
    • Posts: 190
    • Thanks: +0/-0
      • View Profile
    Thanks for the great explaining. :D

    Ive got an error tough :palm: while I try to run the client (Run As - Run Configurations).


    Exception in thread "main" java.lang.Error: Unresolved compilation problem:
       Syntax error, annotations are only available if source level is 1.5 or greater

       at org.virtue.game.core.threads.MainThreadFactory.<init>(MainThreadFactory.java:17)
       at org.virtue.Launcher.<clinit>(Launcher.java:45)


    Any idea what couse this trouble? :confused:
    Btw, run client gives the exact same error!

    I look forward to receiving your reply

    This or this[/url] appear to contain a question similar to yours, your answer might be in there ;).

    Offlineamvoverwizzle

    • Member
    • **
    • Posts: 30
    • Thanks: +0/-0
      • View Profile
    Thanks for the great explaining. :D

    Ive got an error tough :palm: while I try to run the client (Run As - Run Configurations).


    Exception in thread "main" java.lang.Error: Unresolved compilation problem:
       Syntax error, annotations are only available if source level is 1.5 or greater

       at org.virtue.game.core.threads.MainThreadFactory.<init>(MainThreadFactory.java:17)
       at org.virtue.Launcher.<clinit>(Launcher.java:45)


    Any idea what couse this trouble? :confused:
    Btw, run client gives the exact same error!

    I look forward to receiving your reply

    I never got this error :p is your java updated to the latest.


    Offlinesniedzins

    • First Time Poster
    • *
    • Posts: 1
    • Thanks: +0/-0
      • View Profile
    I have error when I run the client.

    Unused client paramater: key=13, value=false
    error_game_js5connect



    How to fix it? I follow all steps

    Offlinebasgolde

    • Member
    • **
    • Posts: 10
    • Thanks: +0/-0
      • View Profile
    Fixed the Client by doing: Right click on Client - Properties - Java Compiler - set 1.4 to 1.7.

    Now I can run the Client till it says login with username and password (ofc).

    But the Client wont be able to login because (I think) the server is not on.

    It gives this erros:

    [Virtue Logger]: Welcome to RuneLove 3.
    [Virtue Logger]: Loading cache.
    [Virtue Logger]: Decoding cache index 0
    [Virtue Logger]: Decoding cache index 1
    [Virtue Logger]: Decoding cache index 2
    [Virtue Logger]: Decoding cache index 3
    [Virtue Logger]: Decoding cache index 5
    [Virtue Logger]: Decoding cache index 7
    [Virtue Logger]: Decoding cache index 8
    [Virtue Logger]: Decoding cache index 9
    [Virtue Logger]: Decoding cache index 10
    [Virtue Logger]: Decoding cache index 12
    [Virtue Logger]: Decoding cache index 13
    [Virtue Logger]: Decoding cache index 14
    [Virtue Logger]: Decoding cache index 16
    [Virtue Logger]: Decoding cache index 17
    [Virtue Logger]: Decoding cache index 18
    [Virtue Logger]: Decoding cache index 19
    [Virtue Logger]: Decoding cache index 20
    [Virtue Logger]: Decoding cache index 21
    [Virtue Logger]: Decoding cache index 22
    [Virtue Logger]: Decoding cache index 23
    [Virtue Logger]: Decoding cache index 24
    [Virtue Logger]: Decoding cache index 25
    [Virtue Logger]: Decoding cache index 26
    [Virtue Logger]: Decoding cache index 27
    [Virtue Logger]: Decoding cache index 28
    [Virtue Logger]: Decoding cache index 29
    [Virtue Logger]: Decoding cache index 30
    [Virtue Logger]: Decoding cache index 31
    [Virtue Logger]: Decoding cache index 32
    [Virtue Logger]: Decoding cache index 33
    [Virtue Logger]: Decoding cache index 34
    [Virtue Logger]: Decoding cache index 35
    [Virtue Logger]: Decoding cache index 36
    [Virtue Logger]: Decoding cache index 37
    [Virtue Logger]: Decoding cache index 38
    [Virtue Logger]: Decoding cache index 39
    [Virtue Logger]: Decoding cache index 40
    [Virtue Logger]: Loaded 31144 item definitions.
    [Virtue Logger]: Loaded 19280 NPC definitions.
    [Virtue Logger]: Loaded 90242 object definitions.
    [Virtue Logger]: Loaded 8078 world NPCs!
    [Virtue Logger]: Loading packets.
    [Virtue Logger]: Creating new account for user: Testrecruiter
    [Virtue Logger]: Initialising clan channel manager.
    [Virtue Logger]: Loading clan index...
    [Virtue Logger]: No clan index file was found.
    [Virtue Logger]: An exception has been caught on engine cycle # 2. Terminating process.
    [Virtue Logger]: Total runtime: 6 seconds, 0 minutes, 0 hours, 0 days.
    org.jboss.netty.channel.ChannelException: Failed to bind to: 0.0.0.0/0.0.0.0:43594
       at org.jboss.netty.bootstrap.ServerBootstrap.bind(Serve
    rBootstrap.java:272)
       at org.virtue.network.ChannelFilter.start(ChannelFilter.java:55)
       at org.virtue.network.RS2Network.load(RS2Network.java:81)
       at org.virtue.Launcher.main(Launcher.java:86)
    Caused by: java.net.BindException: Address already in use: bind
       at sun.nio.ch.Net.bind0(Native Method)
       at sun.nio.ch.Net.bind(Unknown Source)
       at sun.nio.ch.Net.bind(Unknown Source)
       at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
       at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
       at org.jboss.netty.channel.socket.nio.NioServerBoss$RegisterTask.run(NioServerBoss.java:193)
       at org.jboss.netty.channel.socket.nio.AbstractNioSelector.processTaskQueue(AbstractNioSelector.java:372)
       at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:296)
       at org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
       at java.lang.Thread.run(Unknown Source)[/color]

    Anyone knows how to fix this? Thanks!

    OfflineIfearI

    • Member
    • ***
    • Posts: 190
    • Thanks: +0/-0
      • View Profile
    [Virtue Logger]: An exception has been caught on engine cycle # 2. Terminating process.
    [Virtue Logger]: Total runtime: 6 seconds, 0 minutes, 0 hours, 0 days.
    org.jboss.netty.channel.ChannelException: Failed to bind to: 0.0.0.0/0.0.0.0:43594
       at org.jboss.netty.bootstrap.ServerBootstrap.bind(Serve[/color]rBootstrap.java:272)
       at org.virtue.network.ChannelFilter.start(ChannelFilter.java:55)
       at org.virtue.network.RS2Network.load(RS2Network.java:81)
       at org.virtue.Launcher.main(Launcher.java:86)
    Caused by: java.net.BindException: Address already in use: bind <--------------------
       at sun.nio.ch.Net.bind0(Native Method)
       at sun.nio.ch.Net.bind(Unknown Source)
       at sun.nio.ch.Net.bind(Unknown Source)
       at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
       at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
       at org.jboss.netty.channel.socket.nio.NioServerBoss$RegisterTask.run(NioServerBoss.java:193)
       at org.jboss.netty.channel.socket.nio.AbstractNioSelector.processTaskQueue(AbstractNioSelector.java:372)
       at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:296)
       at org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
       at java.lang.Thread.run(Unknown Source)[/color]

    Anyone knows how to fix this? Thanks!


    Is it possible you were already running a server? (You can't run 2 servers on the same port)

    Offlinebasgolde

    • Member
    • **
    • Posts: 10
    • Thanks: +0/-0
      • View Profile
    Yeah I had but i deleted them from my firewall.

    But I cant remember how I put my IP into this new server so it runs on my IP/router.
    ------------------------

    03:38 PM New message (modify)
    Wow i managed to login anyway strange tough.

    Anyone knows how to stop the crashes? Or anything? Thanks! Or to instant level all skills to 99?
    « Last Edit: June 21, 2014, 08:40:08 AM by basgolde »

    Offlineamvoverwizzle

    • Member
    • **
    • Posts: 30
    • Thanks: +0/-0
      • View Profile
    I have error when I run the client.

    Unused client paramater: key=13, value=false
    error_game_js5connect



    How to fix it? I follow all steps

    Make sure you are running your server.

    js5connect error will only show if the server is not running in the background.

    Offlinebasgolde

    • Member
    • **
    • Posts: 10
    • Thanks: +0/-0
      • View Profile
    Got a few issues for this server,

    - Character doesnt attack? (the rat or the guard).
    - I dont hear musictracks from the game?
    - Crashes after 30 sec walking around.
    - Command developer doesnt open if I type ALT + ~.


    Any solution for the ones above?
    Thanks!
    « Last Edit: June 21, 2014, 02:23:37 PM by basgolde »

    Offlineamvoverwizzle

    • Member
    • **
    • Posts: 30
    • Thanks: +0/-0
      • View Profile
    ~
    « Reply #28 on: June 21, 2014, 10:05:45 PM »
    Got a few issues for this server,

    - Character doesnt attack? (the rat or the guard).
    - I dont hear musictracks from the game?
    - Crashes after 30 sec walking around.
    - Command developer doesnt open if I type ALT + ~.


    Any solution for the ones above?
    Thanks!

    The crash dont happen to me useally. the owner dint put music in there, and he dint start the basic att system but only putted slice in the ability move witch does nothing atm. Hold alt ~

    Offlinej to top

    • First Time Poster
    • *
    • Posts: 1
    • Thanks: +0/-0
      • View Profile
    when i try to run the server i get an error that says "could not find the main class: org.virtyue.launcher. Program will exit." Please help.

    Offlineamvoverwizzle

    • Member
    • **
    • Posts: 30
    • Thanks: +0/-0
      • View Profile
    when i try to run the server i get an error that says "could not find the main class: org.virtyue.launcher. Program will exit." Please help.

    Make sure you follow every step. Because you might of not assign the proper class

    Offlineluxeh

    • First Time Poster
    • *
    • Posts: 1
    • Thanks: +0/-0
      • View Profile
    Hey!
    I just get this error up all the time:
    [Virtue Logger]: Welcome to RuneLove 3.
    [Virtue Logger]: Loading cache.
    [Virtue Logger]: An exception has been caught on engine cycle # 0. Terminating process.
    [Virtue Logger]: Total runtime: 0 seconds, 0 minutes, 0 hours, 0 days.
    java.io.FileNotFoundException
       at org.virtue.cache.FileStore.open(FileStore.java:51)
       at org.virtue.cache.tools.CacheLoader.init(CacheLoader.java:22)
       at org.virtue.cache.tools.CacheLoader.getCache(CacheLoader.java:27)
       at org.virtue.Launcher.loadCache(Launcher.java:114)
       at org.virtue.Launcher.main(Launcher.java:82)

    Some1 know what it means or how to fix it?
    Thanks if u reply  :D

    Offlineamvoverwizzle

    • Member
    • **
    • Posts: 30
    • Thanks: +0/-0
      • View Profile
    Hey!
    I just get this error up all the time:
    [Virtue Logger]: Welcome to RuneLove 3.
    [Virtue Logger]: Loading cache.
    [Virtue Logger]: An exception has been caught on engine cycle # 0. Terminating process.
    [Virtue Logger]: Total runtime: 0 seconds, 0 minutes, 0 hours, 0 days.
    java.io.FileNotFoundException
       at org.virtue.cache.FileStore.open(FileStore.java:51)
       at org.virtue.cache.tools.CacheLoader.init(CacheLoader.java:22)
       at org.virtue.cache.tools.CacheLoader.getCache(CacheLoader.java:27)
       at org.virtue.Launcher.loadCache(Launcher.java:114)
       at org.virtue.Launcher.main(Launcher.java:82)

    Some1 know what it means or how to fix it?
    Thanks if u reply  :D

    If you haven't already I would try to start over by making a new folder with a new eclipse folder as well. See if that works.

     

    Copyright © 2017 MoparScape. All rights reserved.
    Powered by SMFPacks SEO Pro Mod |
    SimplePortal 2.3.5 © 2008-2012, SimplePortal